Wednesday, November 30, 2011

Cisco, redistribute static and rip. configure dhcp on router

- R1: dhcp server
- R1 and R2 configure with static route
- R2 and R3 configure with rip version 2
- redistribute on R2

+ R1 configuration
-----------------------
R1#sh run
Building configuration...

Current configuration : 1022 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
enable password cisco
!
!
ip dhcp excluded-address 192.168.10.1 192.168.10.5
!
ip dhcp pool cisco.com
 network 192.168.10.0 255.255.255.0
 default-router 192.168.10.1
 dns-server 124.108.56.1
!
!
!
!
!
!
!
ip domain-name cisco.com
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.10.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial2/0
 ip address 210.100.10.1 255.255.255.252
 clock rate 64000
!
interface Serial3/0
 no ip address
 shutdown
!
interface FastEthernet4/0
 no ip address
 shutdown
!
interface FastEthernet5/0
 no ip address
 shutdown
!
ip classless
ip route 192.168.50.0 255.255.255.0 Serial2/0
ip route 0.0.0.0 0.0.0.0 Serial2/0
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 password cisco
 login
line vty 0 4
 exec-timeout 0 0
 password cisco
 login
!
!
!
end

+ R2 configuration
-----------------------
R2#sh run
Building configuration...

Current configuration : 929 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
!
enable password cisco
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.50.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial2/0
 ip address 210.100.10.2 255.255.255.252
!
interface Serial3/0
 ip address 172.168.100.1 255.255.255.0
 clock rate 64000
!
interface FastEthernet4/0
 no ip address
 shutdown
!
interface FastEthernet5/0
 no ip address
 shutdown
!
router rip
 version 2
 redistribute static metric 5
 network 172.168.0.0
 network 192.168.50.0
 no auto-summary
!
ip classless
ip route 192.168.10.0 255.255.255.224 Serial2/0
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 password cisco
 login
line vty 0 4
 exec-timeout 0 0
 password cisco
 login
!
!
!
end



+ R3 configuration
-----------------------
R3#sh run
Building configuration...

Current configuration : 845 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R3
!
!
!
enable password cisco
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.10.10.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial2/0
 ip address 172.168.100.2 255.255.255.0
!
interface Serial3/0
 no ip address
 shutdown
!
interface FastEthernet4/0
 no ip address
 shutdown
!
interface FastEthernet5/0
 no ip address
 shutdown
!
router rip
 version 2
 network 10.0.0.0
 network 172.168.0.0
 no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial3/0
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 password cisco
 login
line vty 0 4
 exec-timeout 0 0
 password cisco
 login
!
!
!
end


----------------------------------------------------------------------------------------------------------------------------

you can download the cisco packet tracer file by click here

No comments:

Post a Comment