Thursday, January 19, 2012

redistribute static with OSPF

the R2 is the border router, this is its configuration

Router#sh run
Building configuration...

Current configuration : 957 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname Router
!
no logging console
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.10.10.1 255.255.255.240
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial2/0
 ip address 172.16.50.2 255.255.255.248
!
interface Serial3/0
 ip address 172.16.100.1 255.255.255.224
 clock rate 64000
!
interface FastEthernet4/0
 no ip address
 shutdown
!
interface FastEthernet5/0
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 redistribute static subnets
 network 172.16.100.0 0.0.0.31 area 0
 network 10.10.10.0 0.0.0.15 area 0
 network 172.16.50.0 0.0.0.7 area 0
!
ip classless
ip route 192.168.10.0 255.255.255.224 Serial2/0
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 login
line vty 0 4
 exec-timeout 0 0
 login
!
!
!
end




For R1 and R2 configuration you can download packet tracer file pkt redistribute static with OSPF.pkt

No comments:

Post a Comment