Sunday, February 26, 2012

Route summary with RIP v 2


I will configure R1 to summary its loopback interfaces into only one network, so that R3 will receive only 10.10.4.0/22, not the four network (10.10.4.0./24, 10.10.5.0/24, 10.10.6.0/24, 10.10.7.0/24)


- R1 configuration

R1#sh run
Building configuration...

Current configuration : 1028 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.10.4.1 255.255.255.0
!
interface Loopback1
 ip address 10.10.5.1 255.255.255.0
!
interface Loopback2
 ip address 10.10.6.1 255.255.255.0
!
interface Loopback3
 ip address 10.10.7.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.10.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial2/0
 ip address 211.233.10.1 255.255.255.0
 clock rate 64000
!
interface Serial3/0
 no ip address
 shutdown
!
interface FastEthernet4/0
 no ip address
 shutdown
!
interface FastEthernet5/0
 no ip address
 shutdown
!
router rip
 version 2
 redistribute static
 network 192.168.10.0
 network 211.233.10.0
 no auto-summary
!
ip classless
ip route 10.10.4.0 255.255.252.0 Null0
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end

- R2 configuration

R2#sh run
Building configuration...

Current configuration : 747 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.20.1 255.255.255.192
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial2/0
 ip address 211.233.10.2 255.255.255.0
!
interface Serial3/0
 ip address 172.16.20.1 255.255.255.0
 clock rate 64000
!
interface FastEthernet4/0
 no ip address
 shutdown
!
interface FastEthernet5/0
 no ip address
 shutdown
!
router rip
 version 2
 network 172.16.0.0
 network 211.233.10.0
 no auto-summary
!
ip classless
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end

- R3 Configuration

R3#sh run
Building configuration...

Current configuration : 715 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.30.1 255.255.255.128
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial2/0
 ip address 172.16.20.2 255.255.255.0
!
interface Serial3/0
 no ip address
 shutdown
!
interface FastEthernet4/0
 no ip address
 shutdown
!
interface FastEthernet5/0
 no ip address
 shutdown
!
router rip
 version 2
 network 172.16.0.0
 network 192.168.30.0
 no auto-summary
!
ip classless
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end


- R3 Routing Table

R3#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/22 is subnetted, 1 subnets
R       10.10.4.0 [120/2] via 172.16.20.1, 00:00:16, Serial2/0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.20.0 is directly connected, Serial2/0
R    192.168.10.0/24 [120/2] via 172.16.20.1, 00:00:16, Serial2/0
     192.168.30.0/25 is subnetted, 1 subnets
C       192.168.30.0 is directly connected, FastEthernet0/0
R    211.233.10.0/24 [120/1] via 172.16.20.1, 00:00:16, Serial2/0


In routing table os R3 me see only 10.10.4.0/22 ;)


To download Cisco Packet Tracer file Rip v2 route summary.pkt

No comments:

Post a Comment