Sunday, October 5, 2014

Configure OSPF between mikrotik and cisco


1- General Information
- Cisco router:  Lan= f0/1: 192.168.2.1/24
                         Connect to Mikrotik = f0/0 192.168.203.10/24
-Mikrotik router: Lan=ether1: 192.168.202.101/24
                            Connect to Cisco = ether3 192.168.203.101/24

2- Cisco router configuration
interface FastEthernet0/0
 ip address 192.168.203.10 255.255.255.0
 duplex auto
 speed auto
!        
interface FastEthernet0/1
 ip address 192.168.2.1 255.255.255.0
 duplex auto
 speed auto
!        
router ospf 1
 log-adjacency-changes
 network 192.168.2.0 0.0.0.255 area 0.0.0.0
 network 192.168.203.0 0.0.0.255 area 0.0.0.0



3- Configure on Mikrotik

/ip address  add address=192.168.202.101/24 disabled=no interface=ether1 network= 192.168.202.0
/ip address add address=192.168.203.101/24 disabled=no interface=ether3 network= 192.168.203.0

/routing ospf network
add area=backbone disabled=no network=192.168.203.0/24
add area=backbone disabled=no network=192.168.202.0/24



4- show  receive routes
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

O    192.168.202.0/24 [110/20] via 192.168.203.101, 00:18:26, FastEthernet0/0
C    192.168.203.0/24 is directly connected, FastEthernet0/0
C    192.168.2.0/24 is directly connected, FastEthernet0/1



[admin@MikroTik] > ip route print
Flags: X - disabled, A - active, D - dynamic,
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
B - blackhole, U - unreachable, P - prohibit
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 1 A S  0.0.0.0/0                          192.168.202.1             1
 2 ADo  192.168.2.0/24                     192.168.203.10          110
3 ADC  192.168.202.0/24   192.168.202.101 ether1                    0
4 ADC  192.168.203.0/24   192.168.203.101 ether3                    0



No comments:

Post a Comment