Wednesday, December 31, 2014

configure cisco telephony-servic, voip server on router

1- we will do as below

router:
 -  enable telephony-service  router
 -  create dhcp server and use  dhcp option 150 to assign cisco voip configuration

 -  create extensions
 - assign those extensions to the phone

switch:
 - assign vlan voice to port that ip phone connected





- switch configuration
Building configuration...

Current configuration : 1071 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
 switchport voice vlan 1
!
interface FastEthernet0/3
 switchport voice vlan 1
!
interface FastEthernet0/4
!
interface FastEthernet0/5
 switchport voice vlan 1
!
interface FastEthernet0/6
 switchport voice vlan 1
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
 no ip address
 shutdown
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end



- router configuration


Building configuration...

Current configuration : 1427 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname CallManager
!
!
!
!
ip dhcp excluded-address 1.1.1.1
!
ip dhcp pool voip
 network 1.1.1.0 255.255.255.0
 default-router 1.1.1.1
 option 150 ip 1.1.1.1
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/0
 ip address 1.1.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
!
!
!
!
!
!
telephony-service
 max-ephones 36
 max-dn 36
 ip source-address 1.1.1.1 port 2000
!
ephone-dn 1
 number 1001
!
ephone-dn 2
 number 1002
!
ephone-dn 3
 number 1003
!
ephone-dn 4
 number 1004
!
ephone-dn 6
 number 1010
!
ephone 1
 device-security-mode none
 mac-address 0002.1664.1415
 type 7960
 button 1:1
!
ephone 2
 device-security-mode none
 mac-address 0090.214B.5301
 type ata
 button 1:2
!
ephone 3
 device-security-mode none
 mac-address 000C.85E3.61D1
 type 7960
 button 1:3
!
ephone 4
 device-security-mode none
 mac-address 000A.4196.A194
!
ephone 5
 device-security-mode none
 mac-address 00D0.D3D2.3462
!
ephone 7
 device-security-mode none
 mac-address 00E0.B09A.9537
 type 7960
 button 1:6
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end




2- test calling from extension 1010 to 1003

No comments:

Post a Comment