Friday, February 27, 2015

configure ospf with authentication on cisco router

+++ Inforamtion +++
- the authentication key is: cisco
- Router1 has network:  2.2.2.0/24 and   6.6.6.0/24
- Router0 has network:  2.2.2.0/24 and 1.1.1.0/24

** Router1 configuration **

Router1#show running-config
Building configuration...

Current configuration : 837 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router1
!
!
!
!
interface FastEthernet0/0
 ip address 6.6.6.6 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial3/0
 ip address 2.2.2.2 255.255.255.0
 ip ospf authentication
 ip ospf authentication-key cisco

!
interface FastEthernet4/0
 no ip address
 shutdown
!
interface FastEthernet5/0
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes

 area 0 authentication
 network 2.2.2.0 0.255.255.255 area 0
 network 6.6.6.0 0.255.255.255 area 0

!
ip classless
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end


** Router0 configuration **

Router0#show running-config
Building configuration...

Current configuration : 988 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router0
!
!
!
interface FastEthernet0/0
 ip address 1.1.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial3/0
 ip address 2.2.2.1 255.255.255.0
 ip ospf authentication
 ip ospf authentication-key cisco
 clock rate 64000

!
interface FastEthernet4/0
 no ip address
 shutdown
!
interface FastEthernet5/0
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes

 area 0 authentication
 network 2.2.2.0 0.255.255.255 area 0
 network 1.1.1.0 0.255.255.255 area 0

!
ip classless
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

No comments:

Post a Comment