Tuesday, September 20, 2016

configure openflow on mikrotik

*** on controller server
1- install packages
$ sudo apt-get install floodlight

2- start the service
$ sudo /etc/init.d/floodlight start


*** on mikrotik

1- create bridge and map ports to use
/interface bridge add name=br1 protocol-mode=none
/interface bridge port add bridge=br1 interface=ether3
/interface bridge port add bridge=br1 interface=ether4

2- create flow switch and connect to your controller and add ports to it
/openflow add name=fs1 controllers=192.168.202.200
/openflow port add switch=fs1 interface=ether3
/openflow port add switch=fs1 interface=ether4



No comments:

Post a Comment